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What’s in the box? 
 

      
  BrightSign Player           Power Adapter 

                
Rubber feet                Cable Mount      International prongs 

               
    SD slot cover          Cable tie   

 
Tip: Use the cable mount and ties to keep the cables securely attached to your BrightSign player. 
 
Note: An SD card is not included in the package, but it is required for the player to function. 
Note: The BrightSign TD1012 package includes only the tabletop display and power adapter. The solid-state media 
player and battery are built into the display.  
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What is BrightSign? 
A BrightSign player is a standalone digital sign or kiosk controller. Because BrightSign players are non-PC devices with 
no moving parts, they are durable and designed specifically for digital signs, making them an ideal solution for information 
kiosks, retail displays, museum exhibits, and more. 

 

Benefits 

• Everything included: the hardware, the software, and the networking 
• Astonishing full HD quality 
• Reliable solid-state platforms designed specifically for digital signage 
• Support for interactive displays with buttons, touch screens, and more 
• Multi-zone screen layouts and synchronization of multiple displays 
• Versatile networking options allowing remote control of display presentations 

 

Capabilities 
You can use a BrightSign player to do any combination of the following: 

• Play content from a Secure Digital card (SD or SDHC card) or USB Flash drive (the HD120, HD220, HD1020, 
XD230, XD1030, and XD1230 also support SDXC). 

Note: You must format your SD storage using FAT32 for the player to receive network updates and generate logs. 

You should only format the storage using NTFS if you need to play media files that are 4GB or larger in size. 

• Display content on a high-definition monitor or TV. 

• Play looping video, images, and music in HD. 

• Divide the display into separate content windows called zones to play back video and images simultaneously. 

• Play live HD video, including HDCP-secured content, using an ATSC/ClearQAM tuner (available on the XD1230 
only). 
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• Play live video using a USB video dongle accessory.  

Note: Currently, only the HD1010w supports the Live Video module. This can be purchased from the BrightSign 
Store. 

• Schedule content to play at specific times (hour, day, month, year). 

• Create looping displays. 

• Display RSS feeds and other network information. 

• Display HTML5 content (available on the XD230, XD1030, and XD1230 only). 

• Run interactive presentations that playback content based on inputs from buttons, touch screens, mice, and more. 

• Synchronize video playback across multiple BrightSign players. 

• Update software and content remotely with the BrightSign Networking. 

 

Models 

To compare BrightSign models and all the features available for your digital signs, see the BrightSign Product 

Comparison Matrix.  

http://store.brightsign.biz/Store-W1.aspx�
http://store.brightsign.biz/Store-W1.aspx�
http://www.brightsign.biz/products/compare-models/�
http://www.brightsign.biz/products/compare-models/�
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Getting Started 
1. Download the QuickStart.zip file from the following URL: www.brightsign.biz/quickstart. 
2. Unzip the file to a location on your PC.  
3. Double-click the Setup.exe file and follow the on-screen instructions to install the BrightAuthor software. 

  

http://www.brightsign.biz/quickstart�
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Connecting a display 
Using a VGA cable 
 

 
 
Note: The connectors on BrightSign players vary by model. Your BrightSign player may have different connectors from 
those displayed above. 
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Using an HDMI cable 
 

 
 
 
Note: The connectors on BrightSign players vary by model. Your BrightSign player may have different connectors from 
those displayed above. 
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Connecting speakers 
If your presentations include audio, you can route the audio through an HDMI display that you connect to your BrightSign 
player, or you can connect powered speakers to your BrightSign player. 
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Setting up BrightSign Players 
Before you can create and publish presentations, you must first set up the BrightSign players. To set up a player, you 
need to create setup files in BrightAuthor and add those files to a storage device (SD card or USB flash drive). Afterward, 
insert the storage (usually an SD card) into the BrightSign player. Remember that if you are using an SD card, it must be 
formatted using FAT32 for the player to receive network updates and generate logs. 
 
You can set up your BrightSign players for standalone use, add them to a Local Network, add them to the BrightSign 
Network, or set them up for Simple File Networking. Adding players to a network allows you to remotely manage and 
update your BrightSign players and presentations. Alternatively, standalone use requires inserting an updated storage 
device into the BrightSign player each time you want to update content.  
 
To set up your BrightSign player, complete the following steps: 

1. On the menu bar, click Tools > Setup BrightSign unit. 
2. Under Name Specification, enter a name and description for the unit. 
3. Under Network Properties, choose whether you would like to Enable wireless (only some models have wireless 

capability; please see the BrightSign Product Comparison Matrix for more details). Choose your preferred Network 
Connection Priority and click on Advanced Network Setup if you would like to manually configure the player’s IP 
address. This window contains other content download options depending on the Unit Configuration option you 
choose. 

4. Under Firmware, indicate whether you want to update the firmware and to which version. BrightAuthor requires a 
minimum firmware version to correctly publish presentations to a BrightSign player.  

5. Under Unit Configuration, choose one of the four setup options, and then complete the steps: 
• Standalone: Under Unit Configuration, enabling the diagnostic web server and local web server is 

optional. 
• Local File Networking: Under Unit Configuration, enabling the diagnostic web server and local web server 

is optional. 

http://www.brightsign.biz/products/compare-models/�
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• BrightSign Network: Assign the unit to a group. The player will receive presentations assigned to this 
group. Set a Network Connection Frequency and an Update Health Frequency. 

• Simple File Networking: In the URL for web folder text field, set the location from which the unit will 
download presentations. Set a Network Connection Frequency. 
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6. Under Logging, set your logging preferences. 
7. Click Create Setup Files. 
8. Select an SD card or USB flash drive (HD810, HD1010, HD1010w, and HD1020 only) to store the setup files. Click 

OK.  
Note: You must format your SD storage using FAT32 for the player to receive network updates and generate logs. 
You should only format the storage using NTFS if you need to play media files that are 4GB or larger in size. 
9. Turn off your BrightSign player by unplugging the power adapter. Insert the SD card or Flash drive into the unit. 
10. Turn on the BrightSign player by reconnecting the power adapter. 

 

The SD card or Flash drive must remain connected to the BrightSign player, or it will not receive scheduled 
presentations from the network. The BrightSign player has no internal storage and therefore cannot receive content 
without a storage device connected. For a detailed description of all items in the BrightSign Unit Setup window, 
including optional settings, refer to the BrightAuthor User Guide.  

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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Creating presentations 
This guide describes how to create three types of presentations: a full-screen presentation, a multi-zone presentation, and 
an interactive presentation. 

 

Creating a full-screen presentation 
When you need to create presentations with more than one media file, you can use playlists to play multiple files in a loop. 
This section shows you how to create a playlist using BrightAuthor and the sample files provided in the Quick Start kit.  

1. Create a new BrightSign project: 
a. Double-click the BrightAuthor icon on your desktop. 
b. Click File > New Presentation. 
Tip: If you don’t see New Presentation under File, make sure 
you have the Edit, Publish, or Manage tab selected in the 
upper-left side of the screen. 
c. In the Save As field, enter a name for the presentation. 
d. In the Where field, enter the folder where you want to store 

the presentation. Click Browse to navigate to the desired 
folder. 

e. Select your BrightSign Model, Connector type, and Screen 
resolution.  

f. Click Create. 
2. Select the Full Screen template. 
3. Click Choose. 
4. Under Media Library, click Browse and select the Quick Start 

Content folder. 
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5. Drag one or more files to the playlist area. 
6. You can set the order in which files play by dragging them to the playlist area in the desired order. You can change 

the order of files already in the playlist by clicking a file and dragging it to a new position. 
7. To edit how long each file plays in the presentation, right-click a file and click Edit. Change the Time on Screen 

field and click OK. 
8. On the Menu bar, click File > Save… to store your presentation. 
 

For details on publishing the saved presentation, see Publishing Presentations.  
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Creating a multiple zone presentation 
Using BrightSign zones, you can divide your signage screen into windows and play different types of content in each 
window, including video, audio, images, ticker feeds (RSS or text), or date and time. You can also control transitions 
between media files, background color, background image, font, text color, text alignment, and text orientation. 

Below are a few examples of BrightSign zone templates: 

   
        2-Zone           3-Zone           5-Zone 
 
To create a presentation with multiple zones using the sample content, complete the following steps: 
Double-click the BrightAuthor icon on your desktop. 

1. Click File > Open Presentation. 
2. Navigate to the Quick Start Kit folder on your PC and select the folder for your BrightSign model to see the sample 

files. 
3. Do one of the following to open the BrightAuthor project: 

• If your BrightSign player is connected to your display via an HDMI connection, select the HDMI_Zones file. 

• If your BrightSign player is connected to your display via a VGA connection, select the VGA_Zones file. 

4. When prompted to locate one of the files in the project, click Browse, locate the QuickStartKit\Content folder, and 
then select a file in that folder. Click Open. In the Missing Media File window, click Yes.  

• Zone 1 is a Video or Images zone. You can add videos, images, or audio files in this type of zone. If using 
an HD player, you can only have one video zone on screen at a time. If using an XD player, you can have 
up to two. 
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• Zone 2 is an image zone. You can add images to this type of zone, and you can add as many image zones 
as you like to a presentation. 

Note: Next, we’re going to resize Zones 1 and 2 and then add and populate a new zone. 
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5. Resize the existing zones: 
a. Click Layout on the upper-left side of the screen under Edit. 
b. Select and drag the bottom of the Video Or Images zone to make the zone shorter. 
c. Select and drag the bottom of the Images zone to make both zones the same height. 
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Note: Alternatively, you can also make the height and width of each zone exact using the W and H fields on the 
left. 

6. Add a new zone: 
a. Click Add Zone, select Ticker, and then click OK. 
b. Drag the Ticker zone to the lower left corner. 
c. Select and drag a corner of the Ticker zone and resize it to fit below the other two zones. 
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Note: Zone 3 is a Ticker zone. You can add RSS feeds and Text files to this type of zone. You can mix both RSS 
and Text files, and use multiple RSS and Text files in the same Ticker zone. 

7. Populate the Ticker zone: 
a. Click Playlist on the left side of the taskbar next to Layout. 
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b. Under Zone, click Zone 3: This is the Ticker zone. 
c. Under Media Library, click the Text tab. 
d. Click Browse, locate the QuickStartKit\Content folder, and then click OK. 
e. Drag the BrightSign_Text_feed.txt file into the Zone 3 playlist area.  

8. To add an RSS feed instead of a text file, follow the steps above, but replace steps 7c –7e with the following:  
Note: Internet connection and a networked player are required to use RSS feeds. 
c. Under Media Library, click the RSS tab. 
d. Drag the New RSS Feed icon to the playlist and click Add Data Feed. 
e. Enter a name in the Feed Name field. You can use this name to easily select which RSS feed you want to 

use in the future. 
f. Under Feed specification, select Url and enter the web address of your RSS feed. You can also choose to 

create and host RSS feeds using two BrightSign Network features: Live Data Feeds and Dynamic Playlists. 
See the BrightAuthor User Manual for more information on these features. 

g. Click Validate to check whether the URL is a valid RSS feed and click OK. 
h. Use the Select data feed dropdown list to locate the RSS feed you just created. Click OK. 

9. On the Menu bar, click File > Save... to store your presentation. 
10. For details on publishing the saved presentation, see Publishing Presentations. 

  

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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Creating an interactive presentation 
All models except the HD110 support various types of interactivity. For a complete list of features and details for each 
BrightSign model, see the BrightSign Product Comparison Matrix. 
 
This section of the guide will teach you how to create an interactive presentation with a GPIO device attached to your 
BrightSign player. Even if you do not have a GPIO device connected to your BrightSign player, this example can teach 
you the basics of interactive presentations before you attempt more complex projects. Demos for various types of 
presentations (included Linked Zones, Touch Screen, and Button Board) can be download from our website.  
 
To create an interactive button board presentation with the sample content: 

1. Double-click the BrightAuthor icon on your desktop. 
2. Select File > Open Presentation. 
3. Navigate to the Quick Start Kit folder on your PC, and select the folder that corresponds to your BrightSign model.  
4. Do one of the following: 

• If your BrightSign player is connected to your display via an HDMI connection, and you have a button board 
attached to your BrightSign player, select the HDMI_Interactive_Button file. 

• If your BrightSign player is connected to your display via a VGA connection, and you have a button board 
attached to your BrightSign player, select the VGA_Interactive_Button file. 

5. When prompted to locate one of the files in the project, click Browse, locate the QuickStartKit\Content folder, and 
then select a file in that folder. Click Open. In the Missing Media File window, click Yes.  

6. Under Media Library, click Browse and select the QuickStart/Content folder. 
7. Drag the following files to the playlist area on the right side of the screen: Menu_3option.jpg, Zones.mpg. 
8. In the playlist area (in the right side of the screen), click the Menu_2option.jpg thumbnail and press Delete on 

your keyboard. This removes the file as well as all interactive events linked to it. 
9. Set the new Menu image (Menu_3option.jpg) as the Home Screen. The Home Screen (indicated by the Home       

icon), is the first media file that plays in the presentation. If the presentation is a multi-zone presentation, each zone 
must have a Home Screen. 

http://www.brightsign.biz/products/compare-models/�
http://www.brightsign.biz/demos�
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a. Double-click the Menu_3option.jpg thumbnail. 
b. In the Media Properties window, click the Set as initial state box. If the box is already checked, the file is 

currently the Home Screen. 
c. Click OK. 

10. Link the Menu image to the Attract video (Attract.mpg) with the interactive event Button 0. Once the event is 
defined and the Menu image is playing, pressing Button 0 will cause the presentation to transition to the Attract 
video file. To define the interactive event, follow these steps: 

a. Click Button 0 on the event bar. 
b. Click and hold the bottom of the Menu_3option.jpg thumbnail. The pointer will change to a hand. 
c. Drag the hand pointer from the bottom of Menu_3option.jpg to the Attract.mpg thumbnail. 
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11. Link the Menu image to the Interact (Interact.mpg) and Zones (ZONES.mpg) videos with the interactive events 
Button 1 and Button 2, respectively.  
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Once the events are defined and the Menu image is playing, pressing Button 1 will cause the presentation to 
transition to the Interact video. Pressing Button 2 will transition to the Zones video. To define the interactive events, 
follow these steps: 

a. Click Button 1 on the event bar.  
b. Click and hold the bottom of the Menu_3option.jpg thumbnail (the pointer changes to a hand). 
c. Drag the hand pointer to the Interact.mpg thumbnail. 
d. Click Button 2 on the event bar.  
e. Click and hold the bottom of the Menu_3option.jpg thumbnail. 
f. Drag the hand pointer to the Zones.mpg thumbnail. 

12. Link the end of the Attract, Interact, and Zones videos to the Menu image so that the menu reappears when the 
videos finish playing. To define the interactive event, follow these steps: 

a. Click Media End Event on the event bar. 
b. Click and hold the bottom of the Attract_mpg thumbnail. 
c. Drag the hand pointer to the Menu_3option.jpg thumbnail. 
d. Click and hold the bottom of the Interact _mpg thumbnail (by default, the previous interactive event used is 

already selected, so you don’t need to click the Media End Event again). 
e. Drag the hand pointer to the Menu_3option.jpg thumbnail. 
f. Click and hold the bottom of the Zones.mpg thumbnail. 
g. Drag the hand pointer to the Menu_3option.jpg thumbnail. 
Note: If you do not add a Media End event after each video, the videos will loop indefinitely. 

13. On the Menu bar, click File > Save... to store your presentation. 
14. For details on publishing the saved presentation, see Publishing presentations on the following page. 
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Publishing Presentations 
After creating a presentation, you can publish the content to your BrightSign player using one of four methods: Local 
Storage, Local Networking, Simple File Networking, or the BrightSign Network. This guide will teach you how to publish 
your presentations to an SD card and update your BrightSign player manually. For details on the other publishing 
methods, see the BrightAuthor User Guide. 
 
Note: You must format your SD storage using FAT32 for the player to receive network updates and generate logs. You 
should only format the storage using NTFS if you need to play media files that are 4GB or larger in size. 
 
To publish a presentation to an SD card: 

1. Insert an SD card into your computer’s card reader. 
2. Click the Publish tab in the upper-left side of the BrightAuthor screen. 
3. Click Local Storage (below the Publish tab). 
4. Under Presentations, click Browse, select the folder where your presentation is saved, and then click OK. 
5. Select the presentation you want to publish from the list of presentations. 
6. Drag the presentation into the calendar to set a time when the presentation will play. You can expand or contract 

the time range by clicking, holding, and moving the lower border of the colored field. Double-click the presentation 
in the calendar to further customize the playing time. You have the following options when scheduling a 
presentation: 

• (default) The presentation plays during a limited time range on a single, specific day. Customize the range 
by changing the Start and End times in the Event time field. 

• The presentation plays continuously without interruptions or an end time. Select this option by checking the 
Active all day, every day box. 

• The presentation plays for a limited time during a recurring pattern of days. Select this option by checking 
the Recurring Event box. You can further customize whether you want the presentation to play daily, every 
weekday, every weekend, or during certain days of the week. Use the Range of recurrence field to choose 
what dates the recurring event will begin and end. 

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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In the screen shot above, the presentation is set to “Active all day, every day” 
 

7. Under Publish to, click Browse, select the drive where your SD card is located, and then click OK. 
8. Click Publish. When the Publish Complete window opens, click OK. 
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9. Turn off your BrightSign player by unplugging the power adapter. 
10. Insert the SD card used in the above steps into the BrightSign player. 
11. Turn on the BrightSign player by reconnecting the power adapter. 
12. Leave the SD card in the player. A local storage device (SD card or USB flash drive) must always remain inserted 

in the BrightSign player, regardless of which publishing method you are using. The only time a storage device 
should be removed from the player is when you are manually updating its content.  
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Next steps 
Visit these areas of our webpage to get the most from your BrightSign player: 

• Documentation: Get the latest user guides, release notes, scripting references, hardware reference manuals, and 
regulatory guides. 

• Demos: Get an overview of what BrightSign players are capable of by downloading the demos. 
• Tutorials: Get step-by-step instructions on how to use BrightAuthor to create presentations, publish presentations, 

and more. 
• Downloads: Get the latest BrightSign firmware, BrightAuthor software, Autoplay scripts, scripts for manually setting 

the date & time, and scripts for testing button boards. 
• Support: Contact technical support if you are having trouble with your BrightSign player. 

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
http://www.brightsign.biz/demos�
http://www.brightsign.biz/index.php/tutorials/tutorials/�
http://support.brightsign.biz/entries/314637-brightsign-downloads�
http://support.brightsign.biz/anonymous_requests/new�

